If you are not registered or logged in, you may still use these forums but with limited features. Show recent topics
  [Search] Search   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [FAQ]  FAQ 
[Register] Register / 
[Login] Login 
Advance Poll - Broken support in PHP 5.4  XML
Forum Index » Support Forum
Author Message
huntingpeople
Newbie

Joined: 26/01/2014 19:09:59
Messages: 1
Offline

Hi All, I upgraded my PHP installation from PHP 5.2 to 5.4 version and my Advance Poll stopped working. I googled around for the possible causes and found that the register_globals has been dropped in PHP 5.4.
As a possible, quick fix, i changed and added the below lines to my include/config.inc.php file for advance poll -
////////////////////////////////////////////////
foreach ($_REQUEST as $key=>$val) {
${$key}=$val;
}
foreach ($_SERVER as $key=>$val) {
${$key}=$val;
}
foreach ($_COOKIE as $key=>$val) {
${$key}=$val;
}
////////////////////////////////////////////////
With these I was able to fix the admin portion. But however, the front end is still not working. I can see the poll on front-end, but I am not able to vote or see the result. Any help will be appreciated.


Rajeev.
Carbonize
Master
[Avatar]

Joined: 12/06/2003 19:26:08
Messages: 4290
Location: Bristol, UK
Offline

You must be using a very very old version for it to be using globals. Have you tried downloading the latest version and simply updating your files?

Carbonize
I am not the maker of the Advanced Guestbook

get Lazarus
[Email] [WWW] [Yahoo!] aim icon [MSN] [ICQ]
 
Forum Index » Support Forum
Go to:   
Based on the open source JForum