If you are not registered or logged in, you may still use these forums but with limited features. Show recent topics
  [Search] Search   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [FAQ]  FAQ 
[Register] Register / 
[Login] Login 
Page not found  XML
Forum Index » General Discussion
Author Message
osloman
Beginner

Joined: 08/01/2004 17:30:03
Messages: 5
Location: Norway
Offline

Hi everybody,

I am making a script and for the mean time I am testing it home and I use a Apache server.

Now it happens regularly when I am using the Browsers Back button, that the page before can't be found. Sometimes I have to click the Back button several times to get back to find a page again, which often is the startpage.

Probably this problem can be of many different reasons and I know you don't have so much information about the script, but I already want to ask if someone can point me what the reason/reasons are for this problem.

Who can advice me about this?

Greetings

Osloman
Carbonize
Master
[Avatar]

Joined: 12/06/2003 19:26:08
Messages: 4291
Location: Bristol, UK
Offline

We would need more information on what the script does. Are you dynamically creating pages?

Carbonize
I am not the maker of the Advanced Guestbook

get Lazarus
[Email] [WWW] [Yahoo!] aim icon [MSN] [ICQ]
osloman
Beginner

Joined: 08/01/2004 17:30:03
Messages: 5
Location: Norway
Offline

Hi again,

the first page is just a page with a question which you have to answer with yes or select.

the second page you have to fill in two fields

and with the third page starts the problem. Here I start with a session and save the two variable from the second page. Then I check those variables. If they are filled in or correct do this....if the are not filled in or incorrect you are going back to the second page again. I made also a submit back button in that third page and that works fine. But if I use the Browser back button, page 2 is not found anymore.

I don't know where the problem is, I tried now all the things I know. I also have a form on my website and there you can also go back with a submit back button and the Browsers back button and here it works fine.

Hope this is enough info to help me what I am doing wrong.

Greetings

Osloman
Carbonize
Master
[Avatar]

Joined: 12/06/2003 19:26:08
Messages: 4291
Location: Bristol, UK
Offline

Have it tried it on a public server? By that I mean not on your own test server.

Carbonize
I am not the maker of the Advanced Guestbook

get Lazarus
[Email] [WWW] [Yahoo!] aim icon [MSN] [ICQ]
osloman
Beginner

Joined: 08/01/2004 17:30:03
Messages: 5
Location: Norway
Offline

Yes, I just tried it on my website server and it shows the same problem. As soon as I use the browsers back button I return to the page before, but with a page not found site.
Carbonize
Master
[Avatar]

Joined: 12/06/2003 19:26:08
Messages: 4291
Location: Bristol, UK
Offline

Be hard to say without seeing the script in action.

Carbonize
I am not the maker of the Advanced Guestbook

get Lazarus
[Email] [WWW] [Yahoo!] aim icon [MSN] [ICQ]
 
Forum Index » General Discussion
Go to:   
Based on the open source JForum