If you are not registered or logged in, you may still use these forums but with limited features. Show recent topics
  [Search] Search   [Hottest Topics] Hottest Topics   [Members]  Member Listing   [FAQ]  FAQ 
[Register] Register / 
[Login] Login 
Integration of Poll with forums using an Include statement  XML
Forum Index » Support Forum
Author Message
Toysmith
Newbie

Joined: 22/04/2004 00:58:50
Messages: 4
Offline

I am having trouble getting the Advanced Poll 2.03 working with forums from Simple Machines (www.simplemachines.org) using an include in the template to put the poll in a box on the side of the forums. It seems to be feeding the wrong data. The best thing I can do is show you what I posted to the SMF forums.

My post to SMF forums:
*****************
Hi gang,
I'm not sure exactly what to do here but I think I have a problem with a 3rd party PHP app interacting with the forum when I don't want it to. The 3rd party app is a PHP daily poll called Advanced Poll 2.03 (found at http://www.proxy2.de/) which turns out to have a very large number of files so figuring out where the problem is will take me some time if it is an issue with both using the same variable names, etc as the SMF forums.

I was kind of hoping for some advice from someone here who may have crossed this bridge already though because it may just be how I've integrated it.

Ok, first lets take a peek at two things so you can get the picture of what is going on, and before you ask, I am not logged into the forums and am a random visitor for all the following.

1) http://www.gamedemand.com/forum/index.php shows my forums under development (hope you like the design). Take note of the "daily poll" feature in the left column. This is a php include to a 2nd php component that is in turn included into the forum template to "tack on" the left column. Basically the same type of approach as SMF appears to be using in their forums here. The poll doesn't look right, especially that it is missing the vote button (the little square is all that is left) and the "results" link. You can see how it is supposed to look in the next link.

2) http://www.gamedemand.com/templates/left_column.php shows just the left column NOT interacting with the forum engine. As you can see the poll feature works now.

3) A simpler example of this call without all the graphics is http://www.gamedemand.com/templates/comm_nav_poll.php which is a basic php file calling a couple of include once statements.



Peeking at the client side results (relevant portions only) from the left column by itself shows:


Peeking at the client side results (relevant portions only) from the left column once included within the forums shows that what is being fed to the script is now different:

I have tried moving the first include_once statement to the forum template, then call the 2nd statement from my left_column, among some other simple things to make sure whether things had to be within the <head><body><html> etc but nothing changes the results, so obviously it has something to do with including all this within the forum template. If I've thought this through properly, it seems to me that by including it within the forum template, I've sort of bestowed "ownership" of this left_column to the forums which is why it is now subject to the rules of SMF.

Hopefully this is clear enough and has enough detail. If it does not, reply and I'll get what you need to see the whole picture. I could really use the advice of someone more experienced on how I might resolve this problem. Thanks for your time.

-Toysmith
askjabu
Newbie

Joined: 13/05/2021 12:00:43
Messages: 3
Offline

Wow, It is really nice, I have used this advanced version of Poll automation and I found your article very much informative. If you don't mind then I also want to share my experience with this https://octopuscrm.io/ LinkedIn automation tool which is also very advanced and effective for App development.
supovaanna
Beginner

Joined: 01/06/2021 16:56:15
Messages: 10
Offline

Sehr interessant
DeenaPerry
Beginner

Joined: 01/06/2021 06:26:26
Messages: 6
Offline

That's great. I was impressed by your writing. I am happy to see such a topic. Please come to my blog and read it.
how to install iMessage on Windows
 
Forum Index » Support Forum
Go to:   
Based on the open source JForum